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The information contained in this manual, in whole or part, shall not be transcribed or copied without Baker Hughes’ 
written permission.
In no case does this manual guarantee the merchantability of the positioner or the software or its adaptability to a 
specific client needs. Please report any errors or questions about the information in this manual to your local supplier 
or visit valves.bakerhughes.com.

DISCLAIMER
THESE INSTRUCTIONS PROVIDE THE CUSTOMER/OPERATOR WITH IMPORTANT PROJECT-SPECIFIC 
REFERENCE INFORMATION IN ADDITION TO THE CUSTOMER/OPERATOR'S NORMAL OPERATION AND 
MAINTENANCE PROCEDURES. SINCE OPERATION AND MAINTENANCE PHILOSOPHIES VARY, BAKER 
HUGHES COMPANY (AND ITS SUBSIDIARIES AND AFFILIATES) DOES NOT ATTEMPT TO DICTATE SPECIFIC 
PROCEDURES, BUT TO PROVIDE BASIC LIMITATIONS AND REQUIREMENTS CREATED BY THE TYPE OF 
EQUIPMENT PROVIDED. 

THESE INSTRUCTIONS ASSUME THAT OPERATORS ALREADY HAVE A GENERAL UNDERSTANDING OF 
THE REQUIREMENTS FOR SAFE OPERATION OF MECHANICAL AND ELECTRICAL EQUIPMENT IN 
POTENTIALLY HAZARDOUS ENVIRONMENTS. THEREFORE, THESE INSTRUCTIONS SHOULD BE 
INTERPRETED AND APPLIED IN CONJUNCTION WITH THE SAFETY RULES AND REGULATIONS 
APPLICABLE AT THE SITE AND THE PARTICULAR REQUIREMENTS FOR OPERATION OF OTHER 
EQUIPMENT AT THE SITE.

THESE INSTRUCTIONS DO NOT PURPORT TO COVER ALL DETAILS OR VARIATIONS IN EQUIPMENT NOR 
TO PROVIDE FOR EVERY POSSIBLE CONTINGENCY TO BE MET IN CONNECTION WITH INSTALLATION, 
OPERATION OR MAINTENANCE. SHOULD FURTHER INFORMATION BE DESIRED OR SHOULD PARTICULAR 
PROBLEMS ARISE WHICH ARE NOT COVERED SUFFICIENTLY FOR THE CUSTOMER/OPERATOR'S 
PURPOSES THE MATTER SHOULD BE REFERRED TO BAKER HUGHES.

THE RIGHTS, OBLIGATIONS AND LIABILITIES OF BAKER HUGHES AND THE CUSTOMER/OPERATOR ARE 
STRICTLY LIMITED TO THOSE EXPRESSLY PROVIDED IN THE CONTRACT RELATING TO THE SUPPLY OF 
THE EQUIPMENT. NO ADDITIONAL REPRESENTATIONS OR WARRANTIES BY BAKER HUGHES REGARDING 
THE EQUIPMENT OR ITS USE ARE GIVEN OR IMPLIED BY THE ISSUE OF THESE INSTRUCTIONS.

THESE INSTRUCTIONS ARE FURNISHED TO THE CUSTOMER/OPERATOR SOLELY TO ASSIST IN THE 
INSTALLATION, TESTING, OPERATION, AND/OR MAINTENANCE OF THE EQUIPMENT DESCRIBED. THIS 
DOCUMENT SHALL NOT BE REPRODUCED IN WHOLE OR IN PART WITHOUT THE WRITTEN APPROVAL OF 
BAKER HUGHES.

Copyright

All information contained herein is believed to be accurate at the time of publication and is subject to 
change without notice. 
Copyright 2021 by Baker Hughes Company. All rights reserved. 

PN 720035146-779- 0000 Rev. H.
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1. Introduction

ValVue Introduction
The ValVue ( ValVue Main Screen) is a user-friendly interface for using Masoneilan and 
Masoneilan DTMs to setup, control and diagnose Masoneilan control valves. 

Figure 1 ValVue Main Screen
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About This Manual
These instructions are intended to help a field engineer use the ValVue interface to install, 
configure, calibrate and diagnose valves using various proprietary DTM software. If you 
experience problems that are not documented, contact Baker Hughes or your local 
representative.

This is a menu-driven manual, which also maps the menu items to their icon counterparts. 
Additionally, “Getting Started Tasks” on page 41 gives a task-driven list.

Conventions Used in This Manual

Conventions used in this manual are as follows:

√ Italicized letters are used when referencing a term used in the display window, for 
emphasis on important items and for fields where data appears or for user-entered 
data.

√ Actions performed on buttons, checkboxes, etc. appear bolded.

Indicates important facts and conditions.

Indicates a potentially hazardous situation, which if not avoided could 
result in property damage or data loss.

Indicates a potentially hazardous situation, which if not avoided could 
result in death or serious injury.
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Baker Hughes Documentation Resources for Masoneilan 
Products

Baker Hughes publishes several different resources for documentation on Masoneilan 
products: 

√ Bench quick starts contain information related to configuration and testing in a 
bench top environment.

√ Hardware quick starts contain installation information and other basic information 
related to getting a device installed and very generally configured.

√ Hardware instruction manuals contain more complete information for configuration 
of a device. This manual also includes information on background functionality and 
special circumstances useful in installation, configuration and operation/
troubleshooting.

√ Software manuals contain more complete information for the software 
configuration of a device. This manual also includes information on background 
functionality and special circumstances useful in configuration and operation 
(including diagnostics and their interpretation). These manuals represent the same 
source material as the online help.

√ Handheld documents: Give the DD mappings for the product.

Check the website: https://valves.bakerhughes.com/resource-center. 

Related Documentation for ValVue 3

SVI3

√ Masoneilan SVI3 Digital Positioner Advanced Performance Quick Start Guide 
Masoneilan

√ SVI3 Digital Positioner Advanced Performance Installation and Maintenance 
Manual

SVI II AP

√ Masoneilan SVI II AP Digital Positioner Advanced Performance Quick Start Guide 
Masoneilan

√ Masoneilan SVI II AP Digital Positioner Advanced Performance Installation and 
Maintenance Manual

√ Masoneilan SVI II AP Advanced Performance Digital Positioner Bench Quick Start 
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12400

√ Masoneilan 12400 Series Level Transmitter/Controller Instruction Manual & Safety 
Guide

√ 12400 online help

SVi1000

√ Masoneilan SVi1000 DTM Software Instruction Manual

√ Masoneilan SVi1000 Positioner Instruction Manual 

√ SVi1000 Bench Quick Start Manual

√ Pushbutton Guide for SVi1000 (Emerson® 475 Handheld)

SVITM FF

√ SVI FF Digital Positioner Quick Start Guide

√ SVI FF Digital Positioner Instruction Manual

√ SVI FF Bench Quick Start Manual

√ SVI FF Quick Card for the Emerson 475

NOTE If you are new to DTM technology there is a good explanation 
given on the fdtgroup home page. Visit:
https://fdtgroup.org/technology/components/ for an 
explanation of basic frame and DTM concepts.

Masoneilan Help Contacts
√ Email: svisupport@bakerhughes.com

√ Phone:   888-SVI-LINE (888-784-5463)
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2. Installation and Logon

Installation

Requirements

Using the ValVue installation procedures discussed requires basic knowledge of Microsoft® 
Windows® operating systems. Download the Codewrights HART® Communication DTM 
and install.

Hardware and Operating System Requirements

To successfully install and run ValVue software, your computer system must meet or 
exceed the following minimum hardware and software requirements.

√ Windows Server® 2008 R2 SP1, Win-
dows Server® 2008 SP2, Windows 
Server® 2012, Windows Server® 2016, 
Windows® 7 sp1, Windows® 8.0 or 
Windows® 10

√ 4 G of RAM

√ Microsoft.NET Framework 2.0 SP2, 
Microsoft.NET Framework 4.0 FULL, 
and Microsoft.NET Framework 3.5 SP1

√ 10 G of free hard disk space
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HART® Related Issues
Before installing the DTM, determine which port the computer uses for serial (RS-232 or 
USB) communication. The HART® modem uses this port for communication with the 
SVI3 positioner.

HART® Compliance

The SVI3 Advanced DTM requires a HART® compliant communications loop. The 
HART® protocol specifies the noise level, impedance requirements, and configuration of 
the loop. Conventional communications loops consisting of the following components 
meet requirements for HART® compliance.

√ Quality current source having low noise and high impedance

√ Minimum loop impedance of 250 Ohms

√ Twisted pair cable suitable for 4 - 20 mA current loops

When a safe barrier separates the communicating devices, a HART® compliant barrier 
must be used.

You cannot connect or use the DTM and another HART® master 
terminal device (at the same time), for example a handheld device.

Some Distributed Control System output circuits are incompatible 
with the HART® protocol. Connecting a HART® modem to such a 
circuit can cause a process upset. Use a HART® filter. Consult the 
DCS manufacturer to verity that the DCS is compatible with HART®, 
before connecting a HART® modem and using the DTM.
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Installing ValVue and DTM Software
This installs not only the ValVue and DTM software but the SQL Express® software, the 
Masoneilan NI-FBUS-H1 Comm. DTM, CodeWright HART CommDTM, Microsoft® VC++ 
Redistributable package and the .Net framework.

Operation of the SVI3 Advanced DTM requires installation of the following software 
components:

√ SVI3 Advanced DTM software or one of the items listed under below to access the 
SVI3 Advanced DTM: 

PACTWare software, which includes generic HART® DTM software and 
HART® communications software

AMS Version 13 or above

PRM software from Yokogawa

Field Device Manager (FDM) from Honeywell

fdtContainer from M&M Software GmbH

If you have a previous installation of the Masoneilan NI-FBUS-H1 
Comm. DTM, you need to use Control Panel to uninstall before 
proceeding.

During the install, SQL is installed. It is highly recommended that you 
check for ValVue updates on the Baker Hughes website 
(https://valves.bakerhughes.com/resource-center) every six months 
to keep this program current for security issues.
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To install the software:

1. Double-click ValVue3.xFullEditionInstaller.exe and Figure 2 appears.

Figure 2 Install Unzip

2. Click Install and the extraction process begins. Click to allow instillation on any 
intermediate messages that appear. The Preparing Setup dialog appears. If you have 
not previously installed ValVue3 then Figure 3 appears.

Figure 3 Install Masoneilan NI-FF-H1 Comm. DTM
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3. Click Install and Figure 4 appears.

Figure 4 ValVue Install Welcome

4. Click Next and Figure 5 appears.

Figure 5 ValVue License

During the initial installation, if you do not have SQL installed, you are 
prompted to reboot your system. Follow the prompts to do so and the 
ValVue install automatically commences after reboot.
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5. Click I accept the license....., Next and Figure 6 appears.

Figure 6 Choose Programs for Installation

6. Click Next and Figure 7 appears.

Figure 7 Display Application Status

7. Click Change, navigate to or create the target folder, click OK and the dialog 
reappears.

8. Click Install and the install proceeds followed by the InstallShield Wizard Complete 
dialog.

9. Click Finish.
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Log On
1. Select Start > All Programs > Masoneilan > ValVue3 > ValVue and Figure 8 

appears. 

Figure 8 ValVue Login

2. Sign on to ValVue3 with default values:

User Name: admin

Password: ValVue3

For security purposes, you are forced to change your 
password during the first use.

The ValVue and SV3 DTM license trial period works as 
follows:
1. Once you download and install the ValVue software, you 
are granted a 30 day trial period. During the 30 days, you 
have access to all the advanced features of ValVue and the 
SVI3 DTM.
2. Once the first 30 days expires, you lose the advanced 
features of both ValVue and the SVI3 DTM. You then have an 
additional 30 day period with just standard features, after 
which you must register to continue using the product. 
We strongly encourage you to register your license with us as 
soon as possible. Contact Baker Hughes at 
software.reg@bakerhughes.com.

The evaluation periods for both are independent of each other 
and commence with first use.

NOTE
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3. Use the Authentication pulldown to select either:

√ Windows Authentication: Any user in the list of the ValVue user group can logon. 
This user group is created by the system administrator.

√ ValVue Authentication: This is the default username and password for first login. 
Username Admin and Password: ValVue3. These must be changed after the first 
login.

During your initial login Figure 9 appears.

Figure 9 Change Password

You must change your password according to the constraints shown in Figure 10.

Figure 10 Passwords Constraints

If you have installed/deleted DTMs or updated ValVue, a dialog 
appears when you open ValVue3: Click:

√ Yes and the library is updated.
√ No and you need to manually updated from the DTM Library Man-

agement dialog to access any new functionality.
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√ Login as Current Windows User: Your Domain\Username appear in User Name. 
For:

√ Windows Authentication: Enter a Username, Password and use the Domain 
pulldown to select the domain.

√ ValVue Authentication: Enter a User Name and Password.

√ Login as Current Windows User

4. Click OK and the main screen appears.

After you successfully login into ValVue3, the User Authentication 
Mode is saved and next time you login, the last authentication mode 
automatically appears.

User Account Security Lockout

A user account is locked out after five unsuccessful password entries 
and the following dialog appears:

If this occurs, wait ten minutes and retry. This behavior occurs 
cyclically until a successful login is completed.

The lockout behavior is account specific and occurs when using 
either Login as Windows Authentication or ValVue Authentication.

If you are installing a new version over an existing version, you must 
delete all devices from the topology tree before doing so. After 
reinstalling use the Select the HART® communications network in the 
topology pane, right-click and select Rebuild Network. SVI3
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Failure to Communicate

If the PC (using a modem) fails to communicate with the HART® or ValVue displays then 
either the message No Devices Found in the DTM main screen, or a COM port 
communication error occurs, or the message HART I/O Failed appears if the device 
communications fails during the session. Communication failure prevents the PC from 
establishing a link. Possible causes of communications failure related to installation 
include:

√ Insufficient loop current and voltage

√ Poor wiring contacts

√ Improper connection of the HART® modem to the computer or a busy port (wait for 
COM port to clear or use another port)

√ Incorrect serial port

√ Using the DTM with another HART® master terminal in service

√ Insufficient loop impedance (a minimum of 250 Ohms is required)

√ Field device has a non-zero polling address (Set to multidrop)

If HART® compliance problems are suspect prepare a detailed description of the loop, 
including all devices on the loop, type of wiring used, loop length, and presence of any 
possible interference sources before contacting the factory for assistance.
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3. ValVue Work Environment

ValVue Work Environment
This section describes the ValVue main screen and how to accomplish general ValVue 
tasks. After you have successfully launched and logged into the ValVue, ValVue Main 
Screen appears. The main screen includes four main components:

√  “Command Area”, which includes the title bar, main menu and the toolbar.

√ DTM “UI Panel” on page 31, which displays the UI interface for the specific device 
DTM.

√ Various “Docked Panes” on page 32, which include the topology pane, device library, 
help, and error log tracking.

√ “Status Bar” on page 35.

Figure 11 ValVue Main Screen
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Command Area
Command area is composed of three components: 

√ Title bar: lists the application name and information about current project and 
current opened DTM UI and has buttons to minimize/maximize and close.

 

Figure 12 Title Bar

√ Main menu: Provides items for all functions of the DTM software. See the 
individual menu discussions.

Figure 13 Main Menu

√ Toolbar: An icon-driven representation of the main menu. The number of items and 
those that are active depend on the item selected in the topology. See “Network 
Menu” on page 43 for more description of the icons.

Figure 14 Toolbar

Exclamation Point and Pencil Icons
Throughout ValVue3 and the Masoneilan DTMs a:

√ Red exclamation point ( ) indicates a value in the associated field is out of 
range. 

√ Pencil icon ( ) indicates a value that has not been saved.

These icons also appear in the topology tree to indicate a tab where there is an out of 
range or and unsaved value (Figure 15). The out of range exclamation point always takes 
precedence.

Figure 15 Topology Tree with Icons
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UI Panel
The UI panel depends on the device installed and selected. For Masoneilan products see 
the individual DTM help. See vendor documentation for non-Masoneilan products.

Figure 16 UI Panel
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Docked Panes

ValVue Topology Pane

The topology pane ( ValVue Topology Pane: Network View) is used to navigate the 
various areas and devices in each area and open a device’s proprietary DTM. This 
navigation tree can be changed to one of four different views:

√ Topology View

√ Area View

√ Protocol View

√ Manufacturer View

See “Device Menu” on page 45 for a more detailed explanation.

Figure 17 ValVue Topology Pane: Network View

The tree is broken down into the following functional areas:

√ View: Listed just below the yellow bar is the view in use.

√ Field Network or Area: One level below is either the protocol in use or a listing of 
the user-defined areas.

√ Protocol: Next is the protocol in use.

√ Device: Next is a list of the devices added.
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Column Settings

You can add and remove columns appearing in the topology pane. The default is to 
display a minimal amount of columns and the columns available depend on the active 
Network View. These items are useful in identify particular valve/positioners. It may be 
necessary to pull th e topology pane to display the fields. Columns available for display 
include:

To configure columns:

1. Right-click at the device tag level.

Figure 18 Column Settings Right Click Menu

The image shows the menu when more than the default columns are shown. Only 
Column Settings appears then.

Use the Reset Columns menu item or  on the Column Settings dialog 
to reset the column configuration to default.
Use the Hide This Column menu item to hide a selected column.

2. Click Column Settings and the dialog appears.

Figure 19 Column Settings

3. Use the add and remove buttons to add/remove items from the Hidden Columns or 
Visible Columns lists.

√ Device Tag √ Address

√ Channel √ Device Type (DTM)

√ Changed: Indicates an unsaved parameter change using the pen-
cil icon.
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4. Use the move buttons to arrange the order and click OK. The topology pane appears 
with the columns appearing and arranged as dictated.

Device Library

Use the Device Library to view lists of protocols and devices in the DTM Library. In the 
DTM Library means that they are installed and ready for use by ValVue. Other protocols 
and DTM may be on the system, but not ready. See “DTM Library Management” on 
page 84 for instructions on how to manage DTMs.

Figure 20 Device Library

If you right-click on and item in the Device list you can access a dialog with display only 
DTM Info.

Figure 21 DTM Info
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Error Log Tracking

Accessed from the View menu and clicking  in the status bar, use this, via a 
right-click menu, to view errors, clear errors and view details ( Error Info).

Figure 22 Error Log Tracking Pane

Information in the Error Info dialog can be copied and pasted for troubleshooting 
purposes.

Figure 23 Error Info

Status Bar
This displays the current user and an icon to indicate errors exist. When you mouse over 
the
user label, the tooltip shows the role information. If you click the error icon , the 
Error Log Tracking appears.

Figure 24 Status Bar
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Assign Device Type
If the scan detects a device that is unknown or has unknown device properties, the 
Assign Device Type dialog appears. Use this dialog to review the information gathered 
during the network scan and to add or edit to that data. You can then save the assigned 
data for use with that device type. Only device types that match the specific DTM appear.

Figure 25 Assign Device Type

Fields and Buttons

Save assign-
ment for devices 
of same type

Click this checkbox to save configuration changes made using this dialog for 
devices of the same type once is clicked.

Show all installed 
device types of 
this protocol

Click this checkbox to display all devices scanned that are for the detected pro-
tocol. This is useful to see related information as reference. 

Matching Quality Detects the common quality detected. In this case, this is the protocol.

Device Type Displays the device type detected.

Version Displays the version detected.

Vendor Displays the vendor detected.

Support Level Displays the support level detected.

Matching Quality Displays text associated with the detected Matching Quality as an explanation.
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Configure Assign Device Type

If the Assign Device Type dialog appears:

1. Review the Scan Info fields and ensure that all information is accurate.

2. Click Show all installed device types of this protocol to see information for 
reference, if required.

3. Click Save assignment for devices of same type and click .

Scan Info Displays the scanned data for:
√ Device Type ID
√ Manufacturer ID
√ Protocol
√ Protocol Version
√ Serial Number
√ Bus Address
√ Device

Device Type Info Enter amended data for the scanned data for:
√ Device Type ID
√ Manufacturer ID
√ Protocol
√ Protocol Version
√ Serial Number
√ Bus Address
√ Device
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Topology Right-Click Menu
Use the topology view right-click menu to access functions some of which are ValVue 3 
related and some SVI3 DTM related. Figure 26 shows which items are related to 
positioner DTM operations and which to ValVue 3 (Black boxes are SVI3 operations and 
red are ValVue 3).

Figure 26 Topology Right-Click Menu
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4. How Do I?

Getting Started Tasks

How Do I?

√ “Add a Field Network” on page 55 √ “Add/Remove DTMs in the DTM Updates 
List” on page 85

√ “Work with Device Areas” on page 59 √ “Installation and Logon” on page 19

√ “Add New Device” on page 63 √ “Delete Device Areas” on page 61

√ “Update DTM Library” on page 84 √ “Add an Area and Move Device (s)” on 
page 60

√ “Import Configuration” on page 166

√ “Add a Field Network” on page 55 √ “Filter Events” on page 78

√ “Work with Device Areas” on page 59 √ “Acknowledge Event” on page 79

√ “Add New Device” on page 63 √ “Create Report of Event and Audit Trail” on 
page 79

√ “Add an Area and Move Device (s)” on 
page 60

√ “Export Event and Audit Trail Report” on 
page 81

√ “Delete Device Areas” on page 61 √ “Update DTM Library” on page 84

√ “Register the Product” on page 114 √ “Add/Remove DTMs in the DTM Updates 
List” on page 85

√ “Sequencer Settings” on page 119 √ “HART®” on page 89

√ “Valve Data Management” on page 139 √ “Import Configuration” on page 166

√ “View Events Details” on page 77 √ “Signature Management” on page 148
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5. Network Tasks

Network Menu
Use this menu to structure and rebuild the network.

Menu Items

If ValVue crashes on a Rebuild Hierarchy command while using Win-
dows® XP:

1. Open System Properties.
2. On the Advanced tab select Performance Options.
3. Click Turn on DEP for essential Windows programs and ser-
vices only.

Rebuild 
Network

Performs a Network Scan of all field networks that are connected and correctly 
configured, detecting the network elements and reauthenticating them. If prop-
erly configured the element appears in bold italic type. This process consumes 
an amount of time related to the number of devices on the network.

If you use Rebuild Network, and the device is not connected, the device is 
deleted from the topology tree and its associated settings are removed from the 
database.
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The scan checks the configuration done during the “Add a Field Network” on 
page 55. The general steps involved in adding a field network are:
1. DTM Management (see  “DTM Library Management”).
2. Setting up Field Networks (see “Field Networks” on page 86).
3. Network Communication and Preference Settings (see “Network Communi-
cation Preference Settings” on page 91).
4. Building the Network.

Open Connected 
Device

Performs a search of the field network for all devices whether connected or not, 
connects any unconnected devices and adds related device DTMs to the device 
topology, using the device’s configuration. The Online Parameters tab opens. 
For a gateway DTM, it continues scanning until add all the devices are added. If 
the correct DTM software is not in the Device Library, the Assign Device Type 
dialog appears (see “Assign Device Type” on page 36.) If you choose the wrong 
DTM, the DTM can be assigned to the device, but the DTM cannot communi-
cate with the device.
This command is the preferred method for adding devices to the those shown 
on the topology. If you use Rebuild Network, and the device is not connected, 
the device is deleted from the topology tree and its associated settings are 
removed from the database.

If the scan detects a device that is unknown or has unknown device 
properties, the Assign Device Type dialog appears. Refer to  “Assign 
Device Type” for further explanation.

Refresh Refreshes the screen data and Device Tags.

Exit Exits ValVue, prompting you if all data is not saved.
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6. Device Tasks

Device Menu

Use this menu to structure and rebuild the network.
\

\

Menu Items

When using the right-click menu in the topology pane, you access 
functionality that depends on the whether you access the field net-
work level, communications DTM level or device level.

Device Network and Station level only

Connect All Attempts to connect all DTMs in the Devices Network as per their configuration.
The application operates devices in either connected or disconnected mode. If 
the device is:
√ Not connected, data are stored to the database, and applied when the 

device is connected.
√ Connected, all the functions are available. 
If the Assign Device Type dialog appears, see “Assign Device Type” on page 36. 

Disconnect All Disconnects all DTMs and devices in the Devices Network.

Add a Field 
Network

Opens the Add Field Network - Field Network Tab dialog to configure a new field 
network (“Add a Field Network” on page 87).

Rebuild Network When at the communications DTM level, using this scans the network for all 
devices.

Assign Devices 
To Area

Use this command to create new areas inside an existing area and/or to assign 
devices to an area. You can add child areas to existing areas. See “Work with 
Device Areas” on page 59. 
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Group Devices Opens the Group Devices dialog to performing device grouping. See“Group 
Devices” on page 61.
This choice is available at the communications protocol level as well.

Display Option Opens a sub-menu to choose whether to display in the topology tree:
√ Instrument Only
√ Valve Only
√ Show All
This useful for simplifying the display and is available in the Area View only.

Right click menu for a selected device.
These items are also iconically represented in the tool bar.

Connect Attempts to connect the selected DTM as per its configuration. Double-clicking 
on a device in the Topology tree connects the device and opens the Online 
Parameters tab for the device, if physically connected.
If the Assign Device Type dialog appears, see “Assign Device Type” on page 36. 

Disconnect Disconnects the selected DTM.

Upload 
Parameters from 
Device

Uploads the parameters presently loaded on a selected device.

Download 
Parameters to 
Device

Downloads the parameters presently configured using the UI to a selected 
device.

Offline Parameter Opens the Offline Parameter tab in the DTM UI Panel. See the documentation 
for the proprietary DTM.
This DTM function enables you to adjust parameter values in the project data-
base. Any changes to the parameters of the device do not take effect until the 
data is downloaded. All data created in the DTM is automatically saved to the 
database.

Online Parameter Opens the Online Parameter tab in the DTM UI Panel. See the documentation 
for the proprietary DTM.
This DTM function enables you to do all the online operation to the device.

Configuration Opens the Configuration tab for the FF in the DTM UI Panel. This is the same 
configuration as on the Configuration tab of the “Signature Management” on 
page 148.
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Diagnosis Enables you to observe diagnostics on the device by accessing the individual 
DTM’s Check or Status tabs.

Add Child Area Use this to add a new child area below an existing top level area or child area. 
This is only available in Area View.

Remove Area Use this to remove a child area including all devices with their configuration. 
This is only available in Area View. 

Rename Area Use this to rename a child area. This is only available in Area View.

Run Sequencer Opens the Sequencer Preview dialog. Using this you can access all sequencer 
functionality. See “Sequencer Management” on page 124.

Criticality Level Use the popup to set the criticality level for alarming, which dictates the sam-
pling interval:
√ Very Critical: 60 second interval
√ Critical: 300 second interval 
√ Moderate: 600 second interval (default)
√ Low: 3600 second interval 
√ Do not bother: Not monitored
√ Inherit From Parent Area: Assigns the criticality configured in the parent 

level. This is only available in Area View.
This menu item is only available when a device is selected.
The ValVue 3 Device Criticality settings determine the scan period for monitor-
ing of a positioner. Selecting Do Not Bother means no status is monitored for 
display. Ensure if you use Inherent from Parent Area that the settings do not 
include Do Not Bother. The ValVue 3 Device Status Monitor Running must also 
be active for any status to appear on an individual DTM’s Status tab. Status 
updates for active faults also appear on the Healthy Status and Device Monitor: 
Data Displayed.

Additional 
Functions

The additional functions are device-specific to the device DTM. If available, they 
appear in the sub-menu. For example, the SVI FF DTM includes:
√ Node Address: Opens the Node Address tab to change and save the device 

address.
√ Registration: Opens the registration process.
√ Report: Opens a Configuration Report.
See the individual DTM help files for further explanations.

 Display 
channels/Do not 
display channels

Select the communications DTM level to toggle on/off the displaying of channels 
with a device added or not.

 Display only 
channels with 
device

Select the communications DTM level to toggle on/off the displaying of only 
channels with a device added.
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Open Connected 
Devices

Establishes connection to all connected devices. See “Network Menu” on 
page 43. The Online Parameters tab opens.
If the correct DTM software is not in the Device Library, the Assign Device Type 
dialog appears (see “Assign Device Type” on page 36.) If you choose the wrong 
DTM, the DTM can be assigned to the device, but the DTM cannot communi-
cate with the device.

Add New Device Opens the Add New Device dialog. See “Add New Device” on page 63 for a pro-
cedure.

Import and Add 
New Device

Opens the Import Device Data from File dialog. Use this dialog to import a .ddf 
or .devData file, which contains all the configuration parameters saved from 
another device using Export Device Data. See “Import and Add New Device” on 
page 65 for a procedure. For this release this exists only for https://valves.bak-
erhughes.com/resource-centers.

Delete Field 
Network

Deletes a selected field network if it is not connected and there are no associ-
ated tabs open.

Delete Device Deletes a selected device if it is not connected and there are no associated tabs 
open.

Assign Device Opens the Assign Device dialog to assign a device to an existing device type.

Rename Select rename for a selected item and the cursor is placed in the name for edit-
ing.

Assign Devices 
to Area or Assign 
Devices Under to 
Area

Use this command to create new areas inside an existing area and/or to assign 
devices to an area. You can add child areas to existing areas. See “Work with 
Device Areas” on page 59.

Export Device 
Data

Opens the Export complete valve device and signature history dialog to navi-
gate to a directory and save a device description file (.ddf for earlier than ValVue 
3.6 or .ddf2 for ValVue 3.6+). This later can be loaded onto another https://
valves.bakerhughes.com/resource-center. See “Export Device Data” on 
page 66. Only available for the https://valves.bakerhughes.com/resource-cen-
ter.
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Load 
Configuration to 
Device

Opens the Choose Configuration dialog to choose a configuration that exists. 
This data can then be downloaded to the device using menu commands.

Figure 27 Choose Configuration

Associate to a 
Valve

Opens the Valve Management dialog to associate a positioner to a valve. This 
only available at the positioner level.
Multiple associations are allowed, however, only one association can active at 
anytime. Activation/deactivation is via the right-click menu on the valve level. 
See “Valve Management” on page 139.

Figure 28 Valve Management
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Activate Valve/ 
Deactivate Valve

Activates the selected valve as the valve to which the positioner is connected. 
This also designates the saving of signature date be associated to that valve 
and it is saved to that selected valve’s database.
At any one time there may be no valve activated.

Delete Valve 
Association

Deletes a valve association with a positioner. All data previously gathered is still 
available in the specific valve database. The valve can be added again at a later 
time.

Assign Valve to 
Area

Opens a dialog to assign a valve to a user-created area. See “Work with Device 
Areas” on page 59.

View Diagnostic 
and Report

Opens the View Customize Diagnostics Report dialog to select a test result or 
results to view. Test results can be exported to an Unified Signature format 
(.usf). This is available at both the valve and positioner level. See “View Diag-
nostic and Report” on page 149.

Figure 29 View Customize Diagnostics Report
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Properties and 
Edit Properties 
(valve-level only)

Opens a dialog that is dependent on the topology level.
Communication Interface level: Opens an Info dialog for a selected communica-
tions interface. This dialog has two tabs a Properties tab and a Notes tab where 
you can enter text related to the interface, which is saved by clicking OK.

Positioner level: Opens an Info dialog for a selected positioner. This dialog has 
two tabs a Properties tab and a Notes tab where you can enter text related to 
the positioner, which is saved by clicking OK.
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Valve level: Opens the Valve Details dialog. this data is editable (“Valve Data 
Management” on page 139). 

Import Diagnos-
tic Data

Use this valve-level selection to import signature data for SVI3, SVI II AP, FVP, 
SVi1000 or SVI FF from a legacy device or another DTM. Before the data is 
imported it is checked to ensure it is of the same format - for a similar valve. 
The following dialog appears: 

Use the Browse button to navigate to the desired file.
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Device Monitor: Data Displayed
The following information is monitored at the same polling schedule with the device 
status.

√ Healthy Status

√ Process Variables: Hart® Command 3.

√ Device Mode

√ Device Information: Manufacturer ID, Device Type ID, Device ID, Device Tag.

While in Network View, mouse over to the device status icon (red arrow below) and the 
thee tooltip panel appears and all the online information appears on the tooltip. 

Figure 30 Device Monitor

For HART devices, the healthy status is calculated from the Device Status. One of five 
icons can appears here to indicate the device health:

Healthy - indicates operation is within range.

Maintenance Required - indicates maintenance is necessary.

Out of specification - indicates any specification is out of range and flags the sit-
uation for analysis.

Function check - indicates temporary invalid output.

Failure - indicates failure.
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Table 1 lists the communications protocols and the associated data that can appear.

Table 2 lists the device types and associated process variables that can appear.

Table 1 Communications Protocol

Protocol Data Displayed

HART Device mode

Foundation fieldbusTM Resource block mode, Transducer block mode

Table 2 Device Type

Device Type Data Displayed

SVI3 Signal, Position, Pressure, Supply Pressure

DLT 12300 Current, Level, Current Temperature, External Temperature

DLT 12400 Current, Level, Current Board Temperature, Current Sensor Temperature

SVI II AP Signal, Position, Pressure, Supply Pressure, Pressure2

SVI II ESD Signal, Position, Pressure

SVi1000 Signal, Position

VECTORTM PV Loop Current, PV, Direct Power Voltage, Electronics Temperature

SVI FF Setpoint, Actual Position, Supply Pressure, Actuator Pressure A, Actuator Pres-
sure B

FVPTM Setpoint, Target Position, Actual Position, Pressure
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Add a Field Network
You must be at the Field Network level for this task.

1. Select Device > Add a Field Network and the dialog appears with the Field Network 
tab selected.

Figure 31 Add Field Network - Field Network Tab
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Figure 32 Add Field Network - HART® Network Tab

2. Select a Field Network from the pulldown:

√ HART Modem

√ FF H1 Interface - the NI-FFBus Communications Manager must launch.

√ FF HSE

√ HART IP Communication

√ DCS Communication

√ Other Communication

The Communication DTM automatically populates based on the Field Network 
choice.

The Field Network Name automatically populates to the Field Network with the 
number in sequence of that field network type appended. This is editable.

3. Edit the Field Network Name, if required.
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4. Select Configuration and the appropriate field network tab appears.

Figure 33 Add Field Network - FFTM Configuration Tab

Figure 34 Add Field Network - HART® Configuration Tab
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\

5. Refer to the communication DTM’s online help to configure any features. Under most 
circumstances, this dialog does not need further configuration.

6. Click OK.

When using HART®, you might find it easier to limit the number of 
addresses scanned using the Start address and End Address fields 
to limit scan time.



Masoneilan ValVue Diagnostic Software Instruction Manual =| 59© 2021 Baker Hughes Company. All rights reserved.

Work with Device Areas
This section discusses the functionality for creating device areas and child areas. This 
can be done from several different places in the program and when different menu 
options are active.

When originally opened, all devices found in the network appear under the spare folder 
(plant). By right clicking the Plant folder, you can add a folder (group, or hierarchy). 
Devices under the root folder then can be moved (drag and drop) into any folder/
subfolder; copy is not allowed.

A folder or subfolder can be deleted, and devices under folder to be deleted will be 
automatically placed under the spare folder. Folder can be renamed or moved as well.

Once areas are created, existing specific devices and groups of devices can be assigned 
to that area.

This function is available at all levels including the communications protocol and device 
levels. At the higher level you can assign multiple devices to a new area or an existing 
area. An individual device can be reassigned to a newly created are or an existing area.

Assign a Valve to an Area
1. Select a valve in the directory tree (while in Area View), right-click and select Assign 

Valve to Area and a dialog appears.

Figure 35 Select Area
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2. Select on an existing area and click and a line appears labeled New 
Area. At this moment the cursor is in the field and it can be renamed. Once the cursor 
has left the line, the item can only be renamed in topology pane.

3. Enter a name for the area.

4. Click OK.

Add an Area and Move Device (s)
1. Select a level in the directory tree and click Assign Devices to Area or select a level 

and click Device > Assign Devices to Area and a dialog appears.

Figure 36 Select Area

2. Select on an existing area and click and a line appears labeled New 
Area. At this moment the cursor is in the field and it can be renamed. Once the cursor 
has left the line, the item can only be renamed in topology pane.

3. Enter a name for the area.

4. Click OK.

This menu item changes to Assign Device to Area at the individual 
device level.
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Delete Device Areas

You can use the Remove Area command to delete a selected device area.

Group Devices

Use this functionality to:

√ Group devices under areas created using the “Add an Area and Move Device (s)” 
on page 60

Figure 37 Group Devices

Create a Device Group
1. Select Device > Group Devices or click  and the Group Devices dialog appears.

2. Click the checkboxes associated with the devices.

3. Use the To Area pulldown to select an area created using “Add an Area and Move 
Device (s)” on page 60.

4. Use the With Criticality pulldown to select a level for the group, which includes Inherit 
from Parent Area.

5. Click OK.

You can enter part of the device name in the Tag Filter field and use it 
as a search function.
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Add Child Area
1. Switch Network View to Area View.

2. Select on an existing area and click  in right click menu, and a 
child area appears under the selected area.

Rename Area
1. Switch Network View to Area View.

2. Select on an existing area and click in right click menu, and 
the name of the selected area turns to editable, user can change the name.
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Add New Device
1. Click Add New Device from the Device menu or by right-clicking on a protocol 

and Add New Device - FF appears.

Figure 38 Add New Device - FF
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Figure 39 Add New Device - HART

The dialog appears with the devices listed from the most recent catalog update. See  
“DTM Library Management” to update the device catalog.

2. Select a device, click OK and the device appears under the area selected.

At this point you can configure the device using a proprietary DTM.
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Import and Add New Device
Use this feature to add the information from an existing positioner into the topology tree. 
The information imported comes from a .ddf, .ddf2 or .devData file. The file is created 
using the Export right-click menu item for a selected existing positioner. This is a useful 
tool in facilities where positioner configurations are very similar.

.ddf files contain: DTM device type, DTM data, device information (device ID and device 
tag), valve Information, as well as test information and related sequencer execution 
information.

.devData files contain all data except the valve information.

To do this:

1. Select the device in the topology tree at the communications DTM level, right-click 
and select Import and Add New Device and Figure 40 appears.

Figure 40 Import and Add New Device

2. Navigate to, select the correct file and click Open. A device of the same type appears 
in the topology tree with all of the original positioner settings configure and 
measurement data in the DTM. 

There is no default directory where these files are stored.
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Export Device Data
Use this feature to export the information from an existing positioner to a device 
description files (.ddf for earlier than ValVue 3.6 or .ddf2 for ValVue 3.6+). This is a useful 
tool in facilities where positioner configurations are very similar.

1. Select in the device in topology tree, right-click and select Export Device Data and 
Figure 41 appears.

Figure 41 Export Device Data

2. Navigate to the correct directory file, enter a file name and click Save. 

There is no default directory where these files are stored.
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Copying a Configuration from Device to Device

The overall process for copying a configuration from device to device consists of:

1. Connect positioner with the desired configuration. Connect with ValVue3 and the 
DTM (for, example the https://valves.bakerhughes.com/resource-center DTM). If 
necessary download data into the positioner.

2. Export all data. See“Export Device Data” on page 66.

3. Disconnect device and connect new target device. Connect with ValVue3 and the 
DTM (for, example the https://valves.bakerhughes.com/resource-center DTM).

4. From the ValVue3 right-click menu select Import and Add Device. The Import Device 
From Valve File dialog appears.

Figure 42 Import Device From Valve File

5. Navigate to the file you exported, select it and click Open.

6. At new imported DTM, click Connect. If a dialog pops up to Upload all parameters 
from Device, click No.

7. Download the data to the new device.

There is also and Import/Export function available in the DTM. 
See the DTM documentation.
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7. View Tasks

View Menu
Use this menu to set the view of ValVue3 user interface.

Menu Items

Device Network and Station level only

Network View The Network View pane appears on the left side of the screen and at anytime 
can display one of the following views:
√ Topology View - Shows the communication protocols and devices installed 

with them.

Figure 43 Topology View Tree
√ Area View - Shows the area structure that is built using the program and the 

devices in each area. Each area is user-added and carries the 
user-assigned label.

Figure 44 Area View Topology
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√ Protocol View - Shows the protocol in use for each device or set of devices.

Figure 45 Protocol View Topology
√ Manufacturer View - Shows the device manufacturer and the devices in the 

area from that manufacturer.

Figure 46 Manufacturers View Topology

Full Screen Toggles the screen to show only the menus and the UI panel. Toggle this off by 
selecting one of the Network Views.

Expand All Expands the protocols and devices shown in the topology pane as dictated by 
selections in View > Network View.

Collapse All Collapses the protocols and devices shown in the topology pane as dictated by 
selections in View > Network View.

View Audit Trail Opens the “Event & Audit Trail Viewer” on page 71 for use in troubleshooting 
and acknowledging events.

Network View Toggles the Network View pane on/off.

Device Library Toggles the Device Library pane on/off.

Error Log Track-
ing

Toggles the Error Log Tracking pane on/off.
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Event & Audit Trail Viewer
Use this feature to:

√ “View Events Details” on page 77

√ “Filter Events” on page 78 for display by type and date range

√ “Acknowledge Event” on page 79 

√ “Create Report of Event and Audit Trail” on page 79 a record of events in PDF 
format

√ “Export Event and Audit Trail Report” on page 81 events to Excel format for later 
printing or to save as a file

Figure 47 Event and Audit Trail Viewer: FF
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Figure 48 Event and Audit Trail Viewer: SVI3 
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Figure 49 Event and Audit Trail Viewer: SVI3

This dialog has five tabs used to present events in the following areas:

√ All: Lists all events.

√ Application: Lists only application level events.

√ Communication: Lists communication events.

√ Device Event: Lists events related to the attached devices.

√ Device Operation: Lists events generated by users requests such as adding 
devices and creating reports.

For each events on all tabs there is a Timestamp, Status, Positioner Tag, User, Event 
Type and Event Description.

An event in the device could be the following:

√ Device Status Change (fault/alarm triggered)

√ Device Status/Healthy Changes

√ Any command from its parent status changed (start, error, complete)
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√ Any operation status changed from within DTM

√ Process Variable Alarm 

√ Communication Event

The Device Status Changes and Healthy Status change are monitored in two ways:

√ A DTM sends notification to ValVue through Standard FDT Event/Audit trail 
interfaces when device status changes (preferred)

√ ValVue sends requests to the DTM via Masoneilan specific interface to get status/
healthy information. 

When a device is online, the DTM sends any event or audit trail information to ValVue via 
standard FDT/DTM event interfaces. 

Device / healthy status change event is polled using the configured update interval, either 
polling with in DTM (preferred), or polling from ValVue.

Audit Trail from ValVue includes: 

√ Application Start/Exit

√ User login/Off

√ Network Settings

√ Security Settings

√ Operations:

Build network

Connect/Disconnect devices

Adding/Deleting Devices

Performing operations to device

Events from ValVue include: 

√ Device stops responding

√ Exception errors

√ Communication Failure
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Table 3 lists the events specific to SVI3.

Table 3 Audit Trail Events for the SVI3

Event Category Event Description

Diagnostics

Run Ramp Test successfully

Run Ramp Test fail.

Run Standard Actuator Signature fail.

Run Standard Actuator Signature successfully.

Run Step test successfully.

Run Step Test fail.

Reset Continuous Diagnostic Data successfully.

Run Clear All Faults successfully.

Run Clear Current Faults successfully.

Reset SVI3 AP successfully.

Calibration

Run Autotune successfully.

Run Autotune fail.

Run Automatic Find Stops successfully.

Run Automatic Find Stops fail.

Set Valve Position to XXXXXX as signal in mA.

The full closed done.

The full open done.

Write Open Stop Adjustment parameter successfully.

Run Live Tuning successfully.

Run Manual Find Stops successfully.

Run Manual Find Stops fail.

The calibration has been reset.

The pressure calibration changed.

The signal calibration finished.

Run Pressure calibration failed.

The open stop adjustment changed.
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Configuration

Download parameters to device successfully.

Write Commission configuration parameters successfully.

Write Retransmitter Range parameters successfully.

Write Output Switches parameters successfully.

Write Device Info parameters successfully.

Write Air Action parameters successfully.

Write PID configuration parameters successfully.

Write Position limits configuration parameters successfully.

Write General configuration parameters successfully.

Write HART configuration parameters successfully.

Write I/O configuration parameters successfully.

Write Option configuration parameters successfully.

Reset Configuration Changed status.

Digital Upgrade Records digital upgrade event.

Cloning Leads you through the process to clone the device.

Reset Reset incidents.

Connect Connect to the device. DeviceID: xxxxxxxxxxxxxx

Disconnect Disconnect to the device. DeviceID: xxxxxxxxxxxxx

Factory Edition
Record the event that ValVue3 temporarily upgrades the diag-
nostic level of SVI3 device to run Signtature tests through SVI3 
DTM.

Data Management Record the events that user exports/imports device data at 
DTM side.

Report Record print DTM report event.

Table 3 Audit Trail Events for the SVI3 (Continued)

Event Category Event Description
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View Events Details

√ Select an event, click  and Event & Audit Trail Details appears.

Figure 50 Event & Audit Trail Details 

Use the “Filter Events” on page 78 to filter events to make 
specific events easier to find.
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Filter Events

You can filter event types or date range. Once filtered, the filter conditions appear in red 
text at the bottom of the filtered list.

Figure 51 Filtered Conditions Parameters

1. Use the event type pulldown to select:

√ Timestamp

√ Positioner Tag

√ User

√ Event Description

√ Event Type

2. Configure the filter conditions. For:

√ Timestamp: Use the two Between dates to set the date range, if required.

√ Positioner Tag, User or Event Description: 

a. Use the pulldown to select:

Equals: Indicates search for an exact string

Contains: Indicates search for a string with the enter data anywhere

isNull: Indicates search for an empty entry

b. Enter text,

√ Event Type:

a. Use the pulldown to select Equals.

b. Use the pulldown to the right to select an event type.

3. Click Show Suppressed to show repeat events. If unchecked, repeat events are not 
shown, even if device status is changed.

4. Click .

Use the  to remove the filter conditions from the 
dialog.



Masoneilan ValVue Diagnostic Software Instruction Manual =| 79© 2021 Baker Hughes Company. All rights reserved.

Acknowledge Event
√ Select an event and click . The acknowledged event grays out.

Create Report of Event and Audit Trail

Print the filtered or unfiltered events to a pdf format, which can then be printed out.

1. Perform a filter function, if required (“Filter Events” on page 78).

2. Click  and the Report Setup appears.

Figure 52 Report Setup
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3. Select one of the radio buttons and add a range for Pages, if applicable, click OK and 
a pdf of the report appears.

Figure 53 PDF of Event Report
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Export Event and Audit Trail Report

Use this to export event details to an Excel spreadsheet.

1. Perform a filter function, if required (“Filter Events” on page 78).

2.  Click  and the Export Setup Range dialog appears. 

Figure 54  Export Setup Range

3. Select one of the radio buttons and add a range for Pages, if applicable, click OK and 
the Export Save As dialog appears. 

Figure 55 Export Save As
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4. Enter a filename, click Save and the report appears.

Figure 56 Exported Event Excel Report
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8. Settings Tasks

Settings Menu
Use this menu to manage the DTM available to the program, map field networks to DTMs, 
configure all aspects of field networks and their operation, including security.

Menu Items

DTM Library Opens DTM Library Management for updating available DTMs and DTM man-
agement. See “DTM Library Management” on page 84 for more information.

Field Networks Opens Field Networks to map ValVue field networks to user-defined configura-
tions. See “Field Networks” on page 86 for more information.

Device Type 
Assignments

Opens the Device Type Assignments dialog where you create a catalog of asso-
ciations between a device type and manufacturer data. 

Field Network 
Settings

Use this menu item to configure field network settings, including:
√ Network Communication Preference Settings - Use this dialog for assigning 

a Field Network type to an available DTM. See “Field Network Settings” on 
page 90. 

√ Criticality Polling Schedule - Set the Update Intervals by Device Criticality.
√ Device Criticality Settings - Assign criticalities to devices. 

User Manage-
ment

Opens User Management adding, editing, deleting users and assign privilege 
levels. 
See “User Management” on page 93 for more information.
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DTM Library Management
Use this feature to:

√ “Update DTM Library” on page 84

√ “Add/Remove DTMs in the DTM Updates List” on page 85

Figure 57 DTM Library Management

Update DTM Library

Use this function to scan for DTM that are on the system but not yet loaded into ValVue. 
Once loaded they are available in the DTM Updates list to add into the DTM Library.

√ Click  and a progress bar appear as the DTM Updates list is 
updated.

To see the correct version of ValVue3 or an individual DTM, click 
Help > About for ValVue3 or the About icon for a DTM ). Do not 
reference the Version field in DTM Library Management.
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Add/Remove DTMs in the DTM Updates List

Use this function to move available DTMs between the DTM Updates list where they are 
available for use in field networks and the DTM Updates list where they are not.

The following buttons are used for this purpose:

Add All Adds all the DTMs to the DTM Library list.

Add Sel Adds the selected DTM to the DTM Library list.

Remove Sel Removes the selected DTM to the DTM Updates list.

Remove All Removes all DTMs to the DTM Updates list.
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Field Networks
Use this feature to map ValVue field networks to user-defined configurations. ValVue can 
support multiple field networks. This linked to the current configuration.

You can also delete and existing setting. The data is not retrievable.

Figure 58 Field Networks
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Add a Field Network

FOUNDATION Fieldbus
1. Select Settings > Field Networks and Field Networks appears.

2. Click  and the Add Field Network dialog appears.

Figure 59 Add Field Network - Field Network Tab

3. Select a Field Network from the pulldown. The NI-FBus Communications Manager 
must launch.

The Communication DTM automatically populates based on the Field Network 
choice.

The Field Network Name automatically populates to the Field Network with the 
number in sequence of that field network type appended. This is editable.

4. Edit the Field Network Name, if required.
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5. Select Configuration and the Add Field Network - Configuration Tab appears.

Figure 60 Add Field Network - Configuration Tab

6. Click OK.
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HART®

1. Select Settings > Field Networks and Field Networks appears.

2. Click  and the Add Field Network dialog appears.

Figure 61 Add Field Network - HART Tab

3. Select a Field Network from the pulldown:

√ HART Modem

√ HART IP Communication

The Communication DTM automatically populates based on the Field Network 
choice.

The Field Network Name automatically populates to the Field Network with the 
number in sequence of that field network type appended. This is editable.

4. Edit the Field Network Name, if required.

5. Click OK.
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Device Type Assignments
Use this dialog to create and delete a catalog of association between a DTM and 
Manufacturer ID and Device Type. If you create a new database, this saves the DTM 
association so that it will not need to be recreated. 

Create a Device Type Assignment
1. Click Settings > Device Type Assignments and Device Type Assignments appears.

Figure 62 Device Type Assignments

2. Click Hex Mode to enter data as hex code.

3. Enter a Manufacturer ID and Device Type ID.

4. Select a device type from the Assigned to Device Type pulldown and click OK.

Delete a Device Type Assignment
√ Select a line item and click Delete.

Field Network Settings
Use this menu to configure the following:

√  “Network Communication Preference Settings”

√ “Criticality Polling Schedule” on page 92
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Network Communication Preference Settings
Use this dialog for assigning a supported Field Network type to an available 
communication DTM. 

Figure 63 Network Communication Preference Settings

1. Select an item from Supported Field Network.

2. Select an item from the Default DTM pulldown and click OK.
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Criticality Polling Schedule
Use this feature to set the time in seconds between updates for the criticality levels.

Figure 64 Criticality Polling Schedule

√ Select an Update Interval (s) for the Device Criticality, edit the interval and click 
OK.
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User Management
Use this function to add and manage:

√ Users (“User Manager” on page 94),

√ Roles (“Role Manager” on page 99), 

√ and Groups (“Group Manager” on page 103).

Figure 65 Security Settings Without User Selected
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Figure 66 User Management With User Selected

User Manager

Use this function to view user details, add users, edit user profiles and delete user 
profiles.

View Detail

Opens the view-only user details.

Figure 67 User Details

Add User Opens the details for adding a new user. See “Add a New User” 
on page 95.
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Add a New User

Use this function to add new users to the program.

1. Click  and the User Manager tab appears.

Figure 68 User Details Adding a New User

2. Use the Authentication pulldown to select an authentication type:

√ ValVue Authentication - Default User Name: Admin and Password is ValVue3. 
This password must be changed after initial login. Use the Group Manager to add 
groups for use.

√ Windows Authentication - Use Windows® credentials. Use the Group Manager to 
add a Windows® or domain user, if the logged in user is in a ValVue domain.

3. Enter a unique Login Name. For Windows Authentication, you must enter the correct 
Windows®/domain user name.

Edit User Opens the details for editing. See “Edit a User” on page 97.

Delete User Deletes the selected user. See “Delete a User” on page 98.

Refresh Refreshes the dialog.
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4. Enter a Password and Confirm Password. Passwords must contain three of the four 
following requirements:

√ Uppercase characters

√ Lowercase characters

√ Numbers

√ Non alphanumeric characters. 

5. Use the Role pulldown list to select a role. The system roles are:

6. Use the Selected checkbox associated with the privileges to extend.

7. Enter Comments related to the user.

8. Click Save.

√ Administrator - Roles are defined in 
the fdt specification.

√ MaintenanceEngineer

√ PlanningEngineer √ SystemObserver

√ SystemOperator
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Edit a User

Use this function to edit an existing user.

1. Select a user and click  and the User Manager tab appears.

Figure 69 User Details Editing a User

2. Enter a changed Password and Confirm Password, if required.

3. Use the Role pulldown list to select a role, if required. 

4. Use the Selected checkbox associated with the privileges to change, if required.

5. Edit the Comments related to the user, if required.

6. Click Save.
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Delete a User

Use this function to delete an existing user.

1. Select a user and click  and the Confirm to Remove dialog appears.

Figure 70 Confirm to Remove

2. Click Yes. 

View Detail
√ Click  and the dialog appears.

Figure 71 View Detail
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Role Manager

Use this function to view role details and edit roles. You can not delete or add roles as the 
roles are part of various FDT DTM operations. 

Figure 72 Role Manager with No Role Selected

Figure 73 Role Manager with a Role Selected
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Buttons and Fields

View Detail

Opens the view-only role details.

Figure 74 Role Details

Edit Role Opens the role for editing. See “Edit a Role” on page 101.



Masoneilan ValVue Diagnostic Software Instruction Manual =| 101© 2021 Baker Hughes Company. All rights reserved.

Edit a Role

Use this function to edit an existing role.

1. Select a role and click  and the Role Manager tab appears.

Figure 75 User Details Editing a Role

2. Edit the description related to the role.

3. Use the All Privileges list to select privileges.

4. Add/delete privileges to Selected Privileges by:

√ Using a double-click on a single privilege.

or

√ Selecting a single privilege and clicking  or .

or

√ Clicking  or  to move all items remaining in the list.

5. Click .
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View Role Detail
√ Click  and the dialog appears.

Figure 76 View Role Detail
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Group Manager

Use this function to view group details, edit groups and create mappings.

Figure 77 Group Manager with No Group Selected

Figure 78 Group Manager with a Group Selected
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Buttons and Fields

View Detail

Opens the view-only group details.

Figure 79 Group Details

This is comprised of two tabs:
√ Group - Contains the Group Name, Role, Privilege assigned 

and Description. See “View Group Detail” on page 108.
√ Windows Groups Mapping- Displays the mappings created 

for the group using the edit function. 

Edit Group Opens the group for editing the privileges assigned to a group 
and adding and deleting mappings. See “Edit a Group” on 
page 105.
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Edit a Group

Use this function to edit an existing group. You can configure privileges and add and 
remove Windows Group Maps (“Add a Mapping” on page 106).

1. Click  , select a group, click  and the Group Manager tab

appears.

Figure 80 Group Manager Details Editing a User

2. Edit the Description related to the role.

3. Select a Privilege Name, and select the checkbox (es) related to the rights to extend.

4. Configure Windows Group Mappings (“Add a Mapping” on page 106).

5. Click .
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Add a Mapping

Use this function to add a mapping.

A mapping creates a map between a pre-defined FDT group and either a local PC user 
group or domain user group. 

1. Select a user and click , click Windows Group Mapping and the Add 
a Mapping Empty dialog appears.

Figure 81 Add a Mapping Empty

2. Select a domain:

√ Local laptop.

or

√ A detected Windows® domain.

3. Enter a Group in Windows Group. This must be exactly as in the Group List. 

4. Click  and Mapping Added appears.
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Figure 82 Mapping Added

5. Click the + next to the group in the list and a dialog appears as a scan of the laptop or 
network occurs for users in that group.

6. Click .

The scan can take some time on a network.

Click  to delete an existing mapping.

Click  to refresh the settings for the user group lists.
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View Group Detail
√ Click  and the dialog appears.

Figure 83 View Group Detail
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9. Tools Tasks

Tools Menu
Use this menu to perform licensing functions, add system tasks, configure tasks into 
sequences and run the sequences.

Menu Items

Firmware 
Downloading

Use this feature to change/upgrade the connected positioner’s firmware. The 
firmware upgrade if it represents an:
√ Upgrade of features: Upgrade an electronics board to advanced edition from 

standard edition.
√ Upgrade firmware to fix known issues.
For the upgrade procedure, see “Firmware Download” on page 110.

ValVue Licensing See “If selected the firmware product has valid license available, user can start 
download. A complete download actions include:” on page 111 for more infor-
mation.

Device Status 
Monitor Running

Toggles on/off the Device Status Monitor.

Sequencer 
Settings

Task Settings: Opens the Task Settings dialog where you assign values to they 
system task performed during a user-configured sequence (“Sequencer Man-
agement” on page 124). See “Sequencer Management” on page 124 to config-
ure a sequence of events and “Execute Sequencer” on page 132 to execute the 
sequence.
Sequencer Management: Opens the “Sequencer Management” on page 124 
dialog for adding, editing and deleting sequences of tasks configured in “Task 
Settings” on page 119. This is also accessed via the Executing Sequencer dia-
log.
Execute Sequencer: Opens the Executing Sequencer dialog (see “Execute 
Sequencer” on page 132) to run the sequences (s) created.
Sequencer Execution Management: Open the “Sequencer Execution Manage-
ment” on page 136 dialog to filter and review sequencer operations.

Valve Data 
Management

Valve Management: Add and delete valves assigned to a positioner, along with 
their data, in the topology. See “Valve Management” on page 139.
Signature Management: Import/export signatures and view signature data. 
See“Signature Management” on page 148.

Import 
Configuration

Use this to import configurations from existing positioners. See “Import Configu-
ration” on page 166.
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Firmware Download
ValVue3 now supports upgrading firmware for Masoneilan HART devices (SVI3, SVI II 
AP, SVI II ESD and 12400) with using ISP adapter. Flashing firmware to a virgin unit or 
upgrading firmware that must be running on different type of hardware.

Firmware image file of SVI3 uses fwc format that combines the images of mainboard, 
pneumatic module, option module and LCD module. User can upgrade all the modules of 
SVI3 positioner through one fwc file.

Firmware to be downloaded must be licensed based on the serial number download. 
User needs to purchase firmware license (either with charge or free) from iStore, and then 
a firmware license S/N will be issued. The user needs to send registration request to 
Baker Hughes for license (Key). Each product needs to use a separate S/N.

After the license is activated, user can see the total number of licenses purchased and 
available number of licenses for use.

Following are Part Numbers defined for Firmware Download licensing (based on 1 
download):

Product Part Number Comments

SVI II AP 720075281-888-0000 Support All released firmware

SVI II ESD 720075282-888-0000 Support All released firmware

SVI3 720075285-888-0000 Product to be released

12400 720075284-888-0000 Support All released firmware

SVi1000 720075283-888-0000 Upgrade is not supported now



Masoneilan ValVue Diagnostic Software Instruction Manual =| 111© 2021 Baker Hughes Company. All rights reserved.

If selected the firmware product has valid license available, user can start 
download. A complete download actions include:

√ Validate Selected Firmware

√ Upload existing device image (NVM)

√ Convert existing NVM to new NVM format that new firmware relays on

√ Download New firmware to device

√ Validate download result

√ Restore converted NVM

The Steps for Firmware Download
1. Ensure the positioner is connected, in Setup mode and not in process control. 

2. Unplug the LCD connector if applicable and connect the ISP device from the 
positioner to a COM port on your laptop. 

3. 3. Select Tools > Firmware Downloading and Firmware Download appears.
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4. Use the ISP Port pulldown list to select the COM port where you connected the ISP 
device. Click the reload icon (  ) to refresh the list of ports. If you are unsure which 
COM port you are using open Control Panel > Device Manager > Ports (COM & 
LPT1) to see a list of in use COM ports. 

5. Click Select Firmware and an Open dialog appears. Then navigate to and select the 
firmware to download.
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ValVue Licensing
This section is meant to be a generic discussion of the licensing process for ValVue and 
Masoneilan software DTMs. In this discussion we use ValVue as an example. Dialogs 
that appear differ based on the Masoneilan software is use. For example, the SViTM 1000 
and 12400 DTMs have only 30 day trial periods.

Registration Process

To open the registration dialog:

√ Select Tools > ValVue Licensing for ValVue. 

√ Select a device and then select Additional Functions > Registration for DTMs.

The Masoneilan ValVue Serial Number is obtained by contacting one of our channel 
partners or by contacting Baker Hughes directly (software.reg@bakerhughes.com). 

Figure 84 ValVue Registration

Use the registration dialog (Figure 84) to:

√ “Register the Product” on page 114 - Required before use or at the end of the 30 
day trial period.

√ “Activate License” on page 116 - Required before use or at the end of the 30 day 
trial period.
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Register the Product

To register the product:

1. Enter the serial number in Step 1. The Serial Number auto-fills for the Basic Edition.

2. Click  or click Next and Figure 85 appears.

Figure 85 Contact Information

Use the copy pulldown to import information that has been previously entered 
for another Masoneilan software.
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3. Enter all required information, as marked by *, click  then  and 
click

 and Figure 86 appears.

Figure 86 Email Registration

4. Ensure you have email access, click Yes and the registration email appears using 
your default email setup. The email has an .xml attachment containing licensing 
information. If sending the email fails or you wish to send from a different laptop/PC, 
click No. A dialog appears which you can use to save the file to a location for use.

Figure 87 Browse for Folder

5. Send the email (software.reg@bakerhughes.com). A return email is sent containing 
the activation code. Proceed to “Activate License” on page 116.
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Activate License

To activate the license:

1. Enter the emailed or channel partner acquired software key.

2. Click  and Figure 88 appears.

Figure 88 Included Features

3. Click Close.
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Registration During the Trial Period

The license trial period works as follows:

1. Once you download and install the ValVue software, you are granted a 30 day trial 
period. We strongly encourages you to register your license with us as soon as 
possible. During the 30 days, you have access to all the advanced features of 
ValVue.

2. Once the first 30 days expires, you lose the advanced features. You then have an 
additional 30 day period, after which you must register to continue using the product. 
Contact Baker Hughes at software.reg@bakerhughes.com.

The first time you open ValVue, if the product is on trial, a dialog appears.

Figure 89 Trial Registration Dialog: Newly Installed

After 30 days without purchase or registration, the first time you open the DTM, Figure 90 
appears.

Figure 90 Advanced Features Expired

For DTMs (not ValVue) click:

√  and follow the prompts to register, before the trial com-
pletely expires (see“Register the Product” on page 114).

√  to continue use until the 30 days expires
(see“Register the Product” on page 114).
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After the first time you open an expired license, and you select Additional Functions > 
Registration, Figure 91 appears. When you click OK the registration process starts (see 
“Register the Product” on page 114).

Figure 91 Ongoing Expiration

If you click anywhere in the DTM after the trial period expires, Figure 92 appears. When 
you click OK, the registration process starts (see“Register the Product” on page 114).

Figure 92 Trial Expired
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Sequencer Settings
Sequencer Settings is comprised of:

√  “Task Settings”

√ “Sequencer Management” on page 124

√ “Execute Sequencer” on page 132

√ “Sequencer Execution Management” on page 136

Task Settings
Use the Task Settings dialog to assign values to they system task performed during a 
user-configured sequence. See “Sequencer Management” on page 124 to configure a 
sequence of events and “Execute Sequencer” on page 132 to execute the sequence.

Tasks are predefined and are categorized into three categories: Configuration, 
Calibration, and Diagnostics tasks. The tasks by category are:

Each task will have a unique task ID so that both frame application and DTM understand 
the task and its input/output parameters. ValVue sends each task to Device/DTM through 
its Masoneilan special FDT/DTM interface. The dialog display can be limited to show 
items only by Device Type.

The sequencer should NOT be used when a procedure (e.g. 
Find Stops, Auto Tune, Step Test, Ramp Test, Signature) is 
running in the DTM.

Configuration Calibration Diagnostics

√ Set Tag √ Autotune √ Standard Signature

√ Set Address √ Find Stops √ Extended Signature (AP and SVI3 
only)

√ Air Action √ Run Ramp Test

√ Set Valve Type 
(FF only)

√ Run Step Test

√ Signature Test (SVI FF only)

√ Change Mode √ Clear Faults (AP, SVi1000 and SVI3 
only)
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Input Parameters of Tasks

Input parameters are required in order to execute the task in the device. The table below 
lists all predefined input parameters.

Task Input Parameters Description

Set Tag Device tag (text) Set the device tag.

Set Address Device address 
(integer, 16-255)

Set the device address.

Set Air Action ATC/ATO Configure the actuator to operate as Air to Close, 
or Air to Open.

Set Valve Type Valve Type (Unde-
fined/Linear/Rotary/
Other)

Choose the valve type.

Find Stops √ Travel Range
√ Travel Unit
√ Open Stop 

Adjustment

√ A numeric value, describing the range of travel. 
Is used to calculate the Working Setpoint value 
(Not for SVi1000, SVI II AP and SVI3).

√ Choose unit type (Not for SVi1000, SVI II AP 
and SVI3).

√ Open stop adjustment.

Autotune √ Aggressiveness
√ Supply 

Pressure

√ Choose whether to tune for fast response or no 
overshoot.

√ Air Supply Pressure in psi. 

Changing Mode Target Mode (Out 
of Service/Auto/
Manual)

Choose the target mode.



Masoneilan ValVue Diagnostic Software Instruction Manual =| 121© 2021 Baker Hughes Company. All rights reserved.

Extended Signature √ Start Position
√ Stop Position
√ Speed Level

√ Set the start position in %, required for 
extended signature test.

√ Set the end position in %, required for extended 
signature test.

√ Set the speed from 1 to 10.

Standard Signature √ Speed Level
√ Save to Device

√ Set the speed from 1 to 10.
√ Select To Baseline 1 or 2, To Saved or None 

(SVI3 only).

Clear Faults √ Current
√ All

√ Clears only current faults
√ Clears current and historical faults

Run Step Test Step Test Type: Set 
the step test type. 
Different types of 
step test require dif-
ferent parameters.

Single Step: 
√ Direction (One Way/Both Ways): Set direction, 

required for Single Step and Multiple Steps.
√ Initial Time: Set initial time in seconds, required 

for Single Step, Multiple Steps and Pre-Defined 
Steps (Not for SVi1000, SVI II AP and SVI3).

√ Sample Rate: Enter a number of samples per 
second. Required for all Step tests. Range: 2 to 
20.

√ Start Position: Set the start position in %, 
required for Single Step and Multiple Steps.

√ End Position: Set the end position in %, 
required for Single Step and Multiple Steps.

√ Step Time: Set step time in seconds, required 
for Single Step, Multiple Steps and Pre-Defined 
Steps.

Multiple Steps:
√ Direction (One Way/Both Ways): Set direction, 

required for Single Step and Multiple Steps.
√ Initial Time: Set initial time in seconds, required 

for Single Step, Multiple Steps and Pre-Defined 
Steps (Not for SVi1000, SVI II AP and SVI3).

√ Sample Rate: Enter a number of samples per 
second. Required for all Step tests. Range: 2 to 
20.

√ Start Position: Set the start position in %, 
required for Single Step and Multiple Steps.

√ End Position: Set the end position in %, 
required for Single Step and Multiple Steps.

√ Step Time: Set step time in seconds, required 
for Single Step, Multiple Steps and Pre-Defined 
Steps.

√ Step Size: Set step size in %, required for Multi-
ple Steps.

Task Input Parameters Description
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Pre-Defined Steps:
√ Around Type (Around Middle/Around Current 

Setpoint): Set around type, required for 
Pre-Defined Steps.

√ Direction (Up and Down/Up/Down): Choose 
direction, required for Pre-Defined Steps.

√ Initial Time: Set initial time in seconds, required 
for Single Step, Multiple Steps and Pre-Defined 
Steps (Not for SVi1000, SVI II AP and SVI3).

√ Sample Rate: Enter a number of samples per 
second. Required for all Step tests. Range: 2 to 
20.

√ Step Time: Set step time in seconds, required 
for Single Step, Multiple Steps and Pre-Defined 
Steps.

√ Max Step: Set max step in %, required for 
Pre-Defined Steps.

√ Step Increase: Set step increase in %, required 
for Pre-Defined Steps.

Run Ramp Test Ramp Test Type
(Single Ramp)

√ Direction (One Way/Both Ways): Set direction, 
required for Single Ramp (Not for SVi1000, SVI 
II AP and SVI3). 

√ Initial Time: Set initial time in seconds, required 
for Single Ramp (Not for SVi1000, SVI II AP 
and SVI3).

√ Start Position: Set the start position in %, 
required for Single Ramp.

√ End Position: Set the end position in %, 
required for Single Ramp.

√ Ramp Time: Set ramp time in seconds, 
required for Single Ramp.

√ Sample Rate: Enter a sample rate (per 10 secs) 
between 1 and 10 (Not for SVI FF).

√ Speed Level: Enter a speed level from 1 to 10 
(Not for SVI FF).

√ Ramp Rate: Set ramp rate in %/s, required for 
Single Ramp (Not for SVi1000, SVI II AP and 
SVI3).

Task Input Parameters Description
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Configure Task Settings
1. Use the Device Type pulldown to display only by a particular device type.

2. Click a Task Name and the name appears in the Parameters list and the configurable 
value (s) appear to the right. There can be fields or pulldowns lists.

3. Enter values.

Figure 93 Configurable Parameters

4. Click  and the dialog closes. 
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Sequencer Management
Use the Sequencer Management dialog for adding, editing and deleting sequences of 
tasks configured in Task Settings. This is also accessed via the Executing Sequencer 
dialog.

A sequencer is a set of tasks that ValVue requests device/DTM to perform silently. 
Depending on the physical network, a sequencer tasks can be performed by multiple 
devices concurrently.

Figure 94 Sequencer Management

The sequencer should NOT be used when a procedure (e.g. 
Find Stops, Auto Tune, Step Test, Ramp Test, Signature) is 
running in the DTM.

Once changes are made to an existing sequencer test the 
Save button activates. If you configure a new sequencer, you 
must save it before exiting the dialog.

By default, the software has two sets of sequencers: 
SVI2AP_SVI3_ATO and SVI2AP_SVI3_ATC for SVI3 and 
SVI II AP devices. The sequencers contain items commonly 
used by most users. Take care as these can be deleted. Their 
default directory is: C:\ProgramData\Dresser\ValVue3\Test.
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Add a New Sequence
1. Select Tools > Sequencer Settings > Sequencer Management, click 

and a dialog appears.

Figure 95 Select Device Type

2. Use the Device Type pulldown to limit the list in the dialog that follows, click OK and 
the Sequencer Setup Wizard - New Sequencer dialog appears.

Figure 96 Sequencer Setup Wizard - New Sequencer

Use the middle arrows to cursor the list up/down one at a time.

Use the top icon to add a new empty line.

Use the bottom icon to delete a selected line.

Use this arrow to go to the last item. 

Use this arrow to go to the first item.
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3. Create a new item by:

a. Clicking underneath Task Name or click and a row is inserted, which can 
later be rearranged. 

b. Configuring the associated Stop On Error checkbox.

c. Editing the value for the action in the field that appears in the pane to the right.

d. Repeat steps a through c as required.

4. Click  and a dialog appears.

Figure 97 Enter the Sequencer Name....

5. Enter a unique name and click OK and the Sequencer Management dialog 
re-appears with the sequence added. Once a name is added, you can edit it by 
double-clicking.

Figure 98 Sequencer Management with Sequence Added

When Sequencer Management dialog is opened again the newly added sequence 
appears in the Task Name list in the next position.
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Edit a Sequence
1. Select Tools > Sequencer Settings > Sequencer Management and the dialog 

appears.

2. Select a sequence and click and the Sequencer Setup Wizard - Edit 
Sequencer dialog appears.

Figure 99 Sequencer Setup Wizard - Edit Sequencer

3. Either:

√ Create a new item by:

a. Clicking underneath Task Name or click and a row is inserted, which can 
later be rearranged.

b. Configuring the associated Stop On Error checkbox.

c. Editing the value for the action in the field that appears in the pane to the right.

d. Repeat steps a through c as required.

√ Edit an existing item by:

a. Selecting a task and editing the associated Stop On Error checkbox. 

b. Editing the value for the action in the field that appears in the pane to the right.

c. Repeat steps a and b as required.

4. Click  and the Sequencer Management dialog appears.

Configurable fields 
by Task Name appear 
here for you to enter/
edit values.
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Export a Sequence

Use this function to export a sequencer configuration in a file form (.seq). This can then 
be imported and used for another positioner of the same type.

1. Select Tools > Sequencer Settings > Sequencer Management and Figure 100 
appears.

Figure 100 Sequencer Management

2. Click  and Figure 101 appears.

Figure 101 Save a .seq File
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3. Navigate to the target directory, enter a filename, click Save and Figure 102 appears.

Figure 102 Sequencer Export File Confirmation

4. Click OK. and the Sequencer Management dialog reappears. Click Close.
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Import a Sequence

Use this function to import a sequencer configuration in a file form (.seq). 

1. Select Tools > Sequencer Settings > Sequencer Management and Figure 100 
appears.

Figure 103 Sequencer Management

2. Click  and Figure 104 appears.

Figure 104 Open a .seq File
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3. Navigate to the target directory, select a file, click Open and Figure 105 appears. 

Figure 105 Sequencer Import File Confirmation

4. Click OK. The Sequencer Management dialog reappears. 

5. Click Close.

Delete a Sequence
1. Select Tools > Sequencer Settings > Sequencer Management and the dialog 

appears.

2. Select a sequence and click .
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Execute Sequencer
Execution of a sequencer can apply to one or multiple devices. A device can be added by 
selecting a device in the device tree and by adding a group of devices. You can choose 
whether a sequencer is executed concurrently or sequentially. The execution can also be 
schedule based.

If a sequencer uses different parameters for different positioner, click Detail and ValVue 
lists all tasks and their parameters for all devices. You can then modify parameters before 
a sequencer is executed.

On this dialog you can:

√ Choose a sequence and execute it immediately.

√ Choose a sequence and schedule it to run.

√ Choose sequences on different devices and run them concurrently.

√ Configure a new sequence, save it and run it.

√ View details.

√ Export results.

√ Make changes to a sequencer and then save it.

Figure 106 Execute Sequencer

The sequencer should NOT be used when a procedure (e.g. 
Find Stops, Auto Tune, Step Test, Ramp Test, Signature) is 
running in the DTM.
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Run a Sequencer

Use this dialog to run the sequencer. 

The:

√ Status column icons indicate whether a test is proceeding (green) or failed (red). 

√ Progress column lists messages related to the individual task.

√ Result column displays the individual task result.

1. Use the Sequencer pulldown to either select:

√ An existing sequence. Proceed to step 2.

√ Click Create New Sequencer. Refer to “Add a New Sequence” on page 125 for 
instructions.

2. Click  and the Preview Sequencer dialog appears.

3. Click the checkbox to the left of each device for execution.

Figure 107 Preview Sequencer

4. Click Execute Concurrent to execute sequences on different devices concurrently.

The sequencer should NOT be used when a procedure (e.g. 
Find Stops, Auto Tune, Step Test, Ramp Test, Signature) is 
running in the DTM.
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5. Click either:

√ Start Now: To commence the test as soon as is clicked.

√ Scheduled At: Use the pulldown to set the date on the calendar and enter the time 
in the fields to the date's right.

6. Use the right and left arrows to add/subtract all or individual items or parent and child 
items together to the pane on the right for execution.

7. Click  and the items are executed.

Detail

Click and the Preview Sequencer dialog appears.
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Sequencer Execution Report

This Sequencer Execution Report includes:

√ The report title includes Sequence Name, Task Count and the User.

√ Device Info lists the device information and the task execution summary.

√ Task Execution Summary lists the tasks by Check out item, including timestamps 
and completion status.

√ Task Execution Details lists the results with configured tasks and input parameters 
and errors/results.

√ Configuration: Details the device configuration.

Figure 108 Sequencer Execution Report

Sequencer Execution Report
Sequencer Name: SVI2AP_SVI3_ATC
Task Count: 10
User: LOGON\lg077432sd

Positioner Info:

Positioner Tag: NEW24

Device ID: 16144612

Device Type ID: 202 (0xCA)

Address: 0

Manufacturer ID: 101 (0x65)

Start Time: 5/23/2019 4:28:04 PM

End Time: 5/23/2019 4:57:30 PM

Total Task Count: 10

Succeeded Task Count: 10

Configuration:

Air Action Air To Close Actuator Type Single

Diagnostic Level Position Unit %

Button Lock Allow Local Buttons Language English

Bumpless Enabled Off Bumpless Value 0

Characterization
Type Linear Custom Points In   100.0

Out   100.0

Lower Limit Enabled Off Lower Limit 0.000

Upper Limit Enabled Off Upper Limit 50.000

Position Rate Limit
Up OFF

Position Rate Limit
Down OFF

Position Rate Limit 0.00 Position Error Time 10.00

Tight Shutoff Enabled On Tight Shutoff 0.018

Position Error
Enabled Off Position Error Band 5.00
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Sequencer Execution Management
Use this dialog to view a listing of all sequencer executions (All tab), sequencer 
executions that have been run (History tab) and those that have just been scheduled 
(Scheduled tab), but not executed. Additionally, you can use the filtering functionality to 
sort and present only data of interest.

There are two ways in which a sequencer execution is saved in the database: 

√ If a sequencer is executed, the result of the sequencer is saved under History.

√ If a sequencer is scheduled to run, the input parameters for the sequencer are 
saved as Scheduled sequencer execution.

Figure 109 Sequencer Execution Management
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Fields

Sequencer Name Lists the name of the sequencer as created using “Sequencer Management” on 
page 124.

Scheduled Time Lists the time that the sequence originally was scheduled to run. This field is 
empty if the sequencer was run without being scheduled.

Start Time Lists the time that the sequence originally was run, scheduled or otherwise.

Execute 
Concurrent

Lists whether the sequencer was run concurrently with another sequencer.

Dismissed Lists whether the sequencer was complete or dismissed due to failure or user 
intervention.

Associated 
Devices

Lists all the devices used during the sequencer run.

Filtering 
Operations

Use the filtering features on a tab-by-tab basis to present only the data of spe-
cific
interest. See “Filter Events” on page 138.

Detail button

Opens the Execute Sequencer details dialog for each sequencer as selected.

Report button

Opens a report for the selected Sequencer Name. This report is in pdf and can 
be printed or saved as a Word or Excel file. If a report for selected sequencer 
does not exist, ValVue3 loads test results from the database and generates a 
new report.

Delete button

Deletes the selected Sequencer Name.
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Filter Events

You can filter event types or date range. Once filtered, the filter conditions appear in red 
text at the bottom of the filtered list.

Figure 110 Filtered Conditions Parameters for Sequencer Management

1. Use the event type pulldown to select:

√ Scheduled Time

√ Start Time

√ Sequencer Name

2. Configure the filter conditions. For:

√ Between: Use the two Between dates to set the date range, if required.

√ Sequencer Name: 

a. Use the pulldown to select:

Equals: Indicates search for an exact string

Contains: Indicates search for a string with the enter data anywhere

isNull: Indicates search for an empty entry

b. Enter text.

3. Click .

Use  to remove the filter conditions from the dialog.



Masoneilan ValVue Diagnostic Software Instruction Manual =| 139© 2021 Baker Hughes Company. All rights reserved.

Valve Data Management
This section discusses the capabilities to associate a positioner with a valve and in doing 
so associate, view and analyze test data for that valve. 

Valve Management

Use this window to:

√ Add a valve by importing its data from View a ValSpeQ generated PDF or be 
entering data manually ( “Add a Valve”). For a full discussion of all valve fields, 
refer to the ValSpeQ documentation.

√ Edit data for an existing valve in the database ( “Edit a Valve”).

√ Delete a valve from the database ( “Delete a Valve”).

√ Filter valves displayed using serial number, valve tag and model numbers ( “Filter 
Displayed Valves”).

Figure 111 Valve Management

When using the right-click menu in the topology pane, you access 
functionality that depends on the whether you access the field 
network level, communications DTM level or device level.
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Add a Valve

Use this window to add a valve to the database. It is then available to add to the topology 
and be assigned to a positioner. This can then be used to generate, save and view test 
signatures.

In using the Valve Management window you can effectively create a template for a valve. 
This is useful if you facility has many valves of the same type. 

Information can be extracted from ValSpeQ pdfs and also, for later versions of ValSpeQ 
using a QR or barcode reader, or manually. ValVue3 now supports using QR code 
scanner to import valve spec data only. 

To add a valve:

1. Select Tools> Valve Data Management > Valve Management and the Valve 
Management window appears. 

2. Click and Figure 112 window appears.

Figure 112 Valve Details

Only ValSpeQ generated pdfs are usable. Pdfs created from scanned 
material are not readable.
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There are several means for adding information into the Valve Details window, which 
include:

√ Inputting information directly or editing information that was imported. To input 
data directly: click on one of the labels, for example, Identity and a sub-dialog for 
that data appears (Figure 113). 
Enter the data and click .

Figure 113 Identity Sub-Dialog

√ Alternately, you can scan QR codes for each of the areas represented on the 
Valve Details dialog. To scan, place a cursor in the field in the upper right side of 
the dialog. As data is scanned for each QR code, the data scrolls through this 
area.

3. Figure 114 reappears with all fields populated except Serial Number. On this dialog 
areas with data populated are green-shaded.
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Figure 114 Valve Details Populated

4. Enter a Serial Number and ensure that all the required fields are completed. Not all 
fields are required. 
There are two Serial Number fields:

√ Baker Hughes Format: You can enter the Baker Hughes specific serial number.

√ Free Format: Is populated with free format data manually or by QR code scan - 
even if in Baker Hughes Format.

5. Click .

Edit a Valve

Use this window to edit a valve. It is then available to add to the topology and be assigned 
to a positioner. 

To edit a valve:

1. Select Tools> Valve Data Management > Valve Management and the Valve 
Management window appears. See “Filter Displayed Valves” for a description on 
filtering operations.

2. Select a valve.

3. Click and Figure 115 appears. 
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Figure 115 Valve Details

4. Edit fields as necessary and click . Not all fields are required.

5. Click  and the Valve Management window reappears.
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Delete a Valve

Once you delete a valve, all valve data (test signatures, etc.) are deleted as well and is 
un-retrievable. Save this data before valve deletion. To delete a valve:

1. Select Tools> Valve Data Management > Valve Management and the Valve 
Management window appears. See  “Filter Displayed Valves” for a description on 
filtering operations.

2. Select a valve and click .

Signatures
1. Select Tools> Valve Data Management > Valve Management and the Valve 

Management window appears. 

2. Select a valve, click  and Figure 116 appears with all the signatures in 
the target directory. 
The signature history displayed is for the selected valve. This valve is identified by the 
valve serial number. 

Figure 116 View Signature History
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3. Select as many as required, click  and a Save As dialog appears. 

Figure 117 Export Signatures

4. Enter a Filename, navigate to the directory where signatures are stored, and click 
Save.
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Filter Displayed Valves

Use this feature to limit the number of valves appearing in the Valve Management 
window. This useful in installations where there are a large volume of valve installs.

NOTE The pulldown allows you to filter the signatures shown by: 
Show all valves, Only show active valves, or Only show 
inactive valves.

1. Select Tools> Valve Data Management > Valve Management and the Valve 
Management window appears.

Figure 118 Valve Management

2. Use the leftmost pulldown to select either:

√ Valve Serial Number

√ Valve Tag

√ Model Number
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3. Use the operator pulldown to select either:

Equals: Indicates search for an exact string

Contains: Indicates search for a string with the enter data anywhere

isNull: Indicates search for an empty entry

4. Enter a string in the associated text field.

5. Click the green check and the filter conditions are applied to the valve list.

Click  and the filter conditions are applied.
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Signature Management

Use this feature to view a list of signatures, filter the list, import and export signatures and 
delete signatures. This dialog offers sorting via all column heads. You can:

NOTE A .usf file combines multiple test data, for multiple positioners/
valves into one file,

√ Export and import signatures.

√ Delete signatures. Deletes the signatures from the database.

√ Filter signatures displayed using Positioner Tag, Sig. Type, Valve Serial Number, 
Created Time, Model, Positioner ID, User Name, and Source (“Filter Signatures” 
on page 161).

√ View signature data in a viewer where the results can be compared with other 
results (“View Diagnostic and Report” on page 149).

NOTE ValVue version 3.6 introduces enhanced friction calculations 
for the Standard Signature test. These enhancements amount 
to friction calculations where comparing tests done with earlier 
versions may show differences in precision.

Figure 119 View Signature History
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View Diagnostic and Report

Use this feature to view a test result, view multiple test results and overlay test results for 
comparison. One pane appears for each test type and if multiple tests of one type are 
selected they appear together in that test pane.

1. Select Tools> Valve Data Management > Signature Management and the View 
Signature History window appears.

Figure 120 View/Customize Valve Diagnostic Report
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To view signatures:

√ Select a signature or multiple signatures, click  and Figure 121 
appears. 

Figure 121 View Signature Data

This window has various functionalities that are explained in the Table 4 and the Table 5 
tables. Additionally, if you mouse-hover of a particular test graph line, a tooltip dialog 
appears containing the data for that point.

Figure 122 View Signature Data Tooltip
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Table 4 View Signature Data Menus

Item Description

Print

View Valve Report Open the Report Settings dialog to choose the items that will 
display in the valve report. Then preview the valve report.

Print Open the Report Settings dialog to choose the items that will 
display in the valve report. Then generate a valve report.

Exit Closes the dialog.

Load

Load Test Data Opens the View/View Customize Valve Diagnostic Report 
window from which you can add more signatures to the viewer.

View Consists of one checkbox for each test type (Step Test, Ramp 
Test, Standard Actuator Signature, Extended Actuator 
Signature) to toggle the test on or off on the display.

Table 5 View Signature Data Right-click Menus

Item Description

Print Graph Prints the graphs to the default printer.

Scales Setup Opens this dialog to upper and lower ranges for the scale for 
each graph. The test type dictates what range is available 
based on whether it is for pressure, time, etc.

Show Legend Adds a legend for the curves based on the test type and how 
many individual tests are represented.

Show Data Points Adds data points to each test result for a graph.

Show Setpoints Adds setpoints to the display for a Step Test only.

Grid Line Adds or formats each graph grid line. Choices are: Solid, Dot or 
None.
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Result Analysis Opens the Test Result Analysis dialog. This dialog has content 
based on the test type and accesses a Trend display. See “Test 
Results Analysis and Trend Dialogs” on page 153.

Hide This Graph Hides the selected graph. Once hidden you can retrieve the 
graph using the View menu.

Show This Graph Only Leaves only the selected graph. displayed.

Zoom Out This item is activated once you change the graph scale in the 
graph setup.

Remove Selected Curve Removes the selected curve from the graph.

Export to Excel Opens a Save As dialog to export the data for the displayed 
items to an .xls file.

Table 5 View Signature Data Right-click Menus (Continued)

Item Description



Masoneilan ValVue Diagnostic Software Instruction Manual =| 153© 2021 Baker Hughes Company. All rights reserved.

Test Results Analysis and Trend Dialogs

The data that appears depends on the test type. Each test type dialog is shown below.

Figure 123 Extended Signature Test Results Analysis

Figure 124 Ramp Test Results Analysis
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Figure 125 Standard Signature Test Results Analysis

Figure 126 Step Test Results Analysis

Click to access an associated Trend dialog. Each dialog appears below. The tabs that 
appear are test-dependent. The function of the right-click menu options are given in 
Table 6.

Table 6 Historical Trend Right-click Menu

Item Description

Print Graph Prints the graphs to the default printer.

Show Legend Adds a legend for the curves based on the test type and how many 
individual tests are represented.

Show Data Point Adds data points to each test result for a graph.
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The Ramp Test Results Historical Trend has the following tabs:

Figure 127 Ramp Test Results Historical Trend

Grid Line Adds or formats each graph grid line. Choices are: Solid, Dot or 
None.

Trend Removes or adds a selected curve: Max, Min and Average.

√ Hysteresis + Dead-
band

√ Error

Table 6 Historical Trend Right-click Menu (Continued)

Item Description
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The Step Test Results Historical Trend has the following tabs:

Figure 128 Step Test Results Historical Trend

√ Overshoot √ Average Error

√ T86 √ T63

√ Td
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The Standard Signature Test Results Historical Trend has the following tabs:

Figure 129 Standard Signature Test Results Historical Trend

√ Spring Range √ Friction %

√ Friction
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The Extended Signature Test Results Historical Trend has the following tabs:

Figure 130 Extended Signature Test Results Historical Trend

√ Spring Range √ Friction %

√ Friction
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Export Signatures

To export signatures for use on another system:

1. Select a signature or signatures for export. Click  and a Save As dialog 
appears.

Figure 131 Export Signatures

2. Enter a Filename, navigate to the directory where signatures are stored, and click 
Save. If you selected multiple signatures this coalesces them into one file.



160 | Baker Hughes.  © 2021 Baker Hughes Company. All rights reserved.

Import Signatures

To import signatures:

1. Click  and an Open dialog appears.

Figure 132 Import Signatures

2. Navigate to the directory where signatures are stored, select a file and click 
.

The signatures appear the Select Signature to Report window for use in reports.
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Filter Signatures

Use this feature to filter signatures appearing on the Select Signature to Report dialog. 
Filter signatures displayed using Positioner Tag, Sig. Type, Valve Serial Number, Created 
Time, Model, Positioner ID, User Name, and Source. To filter signatures:

1. Use the leftmost pulldown to select an option:

2. Use the operator pulldown to select either:

√ Equals: Indicates search for an exact string

√ Contains: Indicates search for a string with the enter data anywhere

√ isNull: Indicates search for an empty entry

3. Enter a string in the associated text field.

4. Click the green check and the filter conditions are applied to the signatures list.

5. Click  and the filter conditions are applied.
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Print

Use this feature to configure the items that appear on the report. This then prepares a pdf 
for use. You must have the signature associated with a valve to do this (see “Valve 
Management” on page 139). 

Figure 133 View/Customize Valve Diagnostic Report
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To do this:

1. Select the valve in the topology pane, right-click and select View Diagnostic and 
Report and the View/Customize Valve Diagnostic Report window appears.

Figure 134 View/Customize Valve Diagnostic Report
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2. Select an item(s) and click View Report and the View Signature Data dialog 
appears.

Figure 135 View Signature Data

3. Select an item/s, click Print and the Report Settings window appears.
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Figure 136 Report Settings

4. Activate/deactivate checkboxes as required, click  and a dialog 
appears.

Figure 137 Save As For Valve Report

5. Navigate to the required directory, enter a file name for the pdf and click OK.



166 | Baker Hughes.  © 2021 Baker Hughes Company. All rights reserved.

Import Configuration
Use this feature as a quick means to copy an existing configuration and its parameters to 
another positioner. Data from a ValVue 2.8x positioner can be copied and used on a 
ValVue 3x positioner of the same type.

To import a configuration:

1. Click Tools > Import Configuration and Import Configuration dialog appears.

Figure 138 Import Configuration

2. Click  and the Open .dp File dialog appears. The files have an extension, 
depending on positioner version of .dp, .dp1 or .dp2. These files be default are in the 
Program Data > Dresser > ValVue > SVI2AP > Data directory. As the program is 
used, they may have been placed elsewhere.

Figure 139 Open .dp File
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3. Navigate to the file, click Open and the Import Configuration dialog reappears.

4. Click OK and, if successful, the Import Configuration Success appears.

Figure 140 Import Configuration Success
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10. Window Menu

Use this menu to perform some basic operations on how the software interface appears.

Menu Items

AutoHide All When active ( ), the panes open are minimized to tabs on the 
sides and/or bottom of the screen. Click an item to reopen it.

Reset Layout Reset Layout will close all opened device DTM windows, and return ValVue3 to 
default layout.
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11. Help Menu

Use this menu to access help functions.

Menu Items

Contents Opens the ValVue3 help document.

About Opens the About dialog.

Figure 141 About
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12. Connect Masoneilan Devices to an 
AMS-DeltaV System and Starting Using 

ValVue 
with AMS

You need to download the device DD from https://valves.bakerhughes.com/
resource-center:. You must also have the AMS software installed. Use SVIFF device as an 
example.

1. Add the SVI FF DD into the AMS system by:

a. Launching the Add Device Type program located at \AMS\Bin\ or by clicking Start 
Menu -> AMS Device Manager -> Add Device Type and Add Device Type 
appears.



174 | Baker Hughes.  © 2021 Baker Hughes Company. All rights reserved.

Figure 142 Add Device Type

b. Browse to where the SVI FF DD is located and click OK to add the Device Type.
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2. Connect SVI FF device, then to the DeltaV IO card, and in the DeltaV Explorer click 
Download->Physical Network to scan this device into DeltaV Explorer.

Figure 143 Exploring DeltaV

Wait until the SVI FF device is found.

3. Right-click and click Place in standby.

4. Drag the device from the Decommissioned Fieldbus Devices branch out one branch 
to its corresponding Fieldbus Port branch and Fieldbus Device Properties appears.

Figure 144 Fieldbus Device Properties



176 | Baker Hughes.  © 2021 Baker Hughes Company. All rights reserved.

5. Enter the AMS Device tag for the device, edit other fields as necessary, click OK and 
the Device Commissioning Wizard appears to commission the device.

Figure 145 Device Commissioning Wizard

6. Click Finish to begin commissioning.

7. Click Control Network in the Containers pane and select Download > Control 
Network. Download the control network. The SVI FF device is now installed into the 
DeltaV system.

Figure 146 Download Control Network



Masoneilan ValVue Diagnostic Software Instruction Manual =| 177© 2021 Baker Hughes Company. All rights reserved.

8. Open the AMS Device Manager, and drill down to and select the device. Right-click 
and select Rebuild Hierarchy to find the device in DeltaV.

Figure 147 AMS Device Manager: Rebuild Hierarchy

9. Drill down and select the Fieldbus Controller for the device, right-click and select 
Scan > All Devices to synchronize the parameters of the device.

Figure 148 Scan All Devices
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The Scan Manager appears.

Figure 149 Scan Manager

10. Double-click the device to open the DD to the Configuration/Setup-> Block Mode tab. 
This step increases system performance - leave open.

Figure 150 Configuration/Setup-> Block Mode
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11. Click the Device Diagnostics menu, then click Sensor Measurements and click 
Pressures for best performance. This step increases system performance - leave 
open.

Figure 151 Pressures Tab

12. Open ValVue 3, select Settings > DTM Library and DTM Library Management 
appears.

Figure 152 DTM Library Management
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13. Click Update and when update completes click OK.

14. Click Device Add Field Network to begin adding a new field network.

15. Select the DCS Communication, right-click and select Add a Field Network and 
Add AMS Field Network appears.

Figure 153 Add AMS Field Network

16. Select AMS Communication DTM from the Communication DTM pulldown menu. 
Enter a name for the Field Network Name field and click OK and Configure AMS 
Communication DTM appears.

Figure 154 Configure AMS Communication DTM

17. Enter the AMS Server IP address, then right-click the network and click Connect.
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18. Click Server and click Scan All to scan the entire topology of AMS server into 
ValVue. Then click Network > Open Connected Device from the menu bar to add 
SVI FF DTM for the SVI FF device into ValVue.

Figure 155 ValVue 3 AMS Server Communication Configuration

You can now open the SVI FF DTM UI to do monitor, configuration, calibration and 
diagnostic function for the SVI FF devices. See the online help for instructions.
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13. AMS® Communication DTM

Use the AMS communication DTM to connect the AMS server, which reads and writes 
parameters from the AMS server via OPC. AMS communication DTM supports Masoneilan 
Hart and FF protocol devices.

To use the AMS Communication DTM:

1. Update the ValVue3 device library to add the AMS Communication DTM into ValVue3.

2. Add the Windows® user name and password of the ValVue3 computer into the AMS 
Server. Add into Administrator group and the AMSDeviceManager.

When using ValVue 3 in a large network use the Scan Next Level 
command to load information as in Figure 156.

Figure 156 AMS OPC Scan Next Level
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3. Select the ValVue3 device network level, right-click and select Add a Field Network 
and Add a Field Network with DCS Communication, and set DTM Communication as 
AMS Communication DTM.

Figure 157 Add a Field Network with AMS Communication DTM
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4. Click OK and the AMS Communications Page appears.

Figure 158 AMS Communications Page

5. Set the IP Address of the AMS Server and click OK.
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6. Click Server in the pane to the left and the AMS Server Hierarchy Page appears.

Figure 159 AMS Server Hierarchy Page

7. Connect the AMS Communication DTM and click Scan All. A list of the connected 
devices appears.

8. Choose on a device and add this device into ValVue3. 
For SVI FF device, AMS OPC does not support the read/write parameters of the MIB 
block. So Network Setting parameters in SVI FF DTM do not work under AMS 
Communication DTM.
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14. Masoneilan PRM Communication DTM

“Masoneilan PRM Communication DTM” is a newly added communication DTM in 
ValVue3.60. The goal of this DTM is to integrate ValVue3 with Yokogawa Plant Resource 
Manager (PRM). ValVue3 can communicate with Masoneilan HART and Foundation 
Fieldbus devices that are installed on PRM system through Masoneilan PRM 
Communication DTM. This release will only support HART protocol devices (HART 
Multiplex connection will be supported in next phase). Foundation Fieldbus protocol devices 
will be supported in next phase. 

Connect Field Devices 

Add Field Devices

PRM Communication DTM runs on an operation system that PRM server or PRM client has 
been installed. Below steps show how to add field devices through PRM Communication 
DTM.

1. Install ValVue3.60 full installer package->Open ValVue3.60 and add a Field Network.
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2. Choose Field Network as DCS Communication->Masoneilan PRM 
Communication->Click OK.

3. Connect the Masoneilan PRM Communication DTM in the ValVue3.
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4. Double-click on the Masoneilan PRM Communication DTM to open Configuration 
page->Click Sync With PRM Server button on the Configuration page-> A list of the 
devices that connect to the PRM server will be updated on the PRM Communication 
DTM device pane. Communication Type displays as Unknown if the connected 
device is not HART protocol or Foundation Fieldbus protocol device. 

5. Choose a Masoneilan device to be communicated on the device pane->Click ADD 
button -> The selected device can be added to ValVue3 device network view at the 
left side of the window.
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If user tries to add a device which Communication Type is FF or Unknown, PRM 
Communication DTM pops up a message:

If ValVue3 does not find the matched DTM during adding device, PRM Communication 
DTM pops up a message to guide user manually choose a DTM to match the device that 
user wants to add. 

6. Open Device Type Assignments dialog under ValVue3 Settings menu-> Type in 
Manufacturer ID and Device Type ID based on the information that displays in the 
Device Pane-> Click OK to save the configuration-> Then try to add the device.

Hart Multiplexer connection is not supported in this release.
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Remove Field Devices

User can remove the device from ValVue3 device network view with Delete Device 
Command. After the device is removed, the occupied communication channel will be 
released for the new device that user wants to add.
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ESD Device Connection

If user tries to add Masoneilan ESD device, there is limit on the number of communication 
channel. PRM Communication DTM can provide up to 100 communication channels for 
ESD devices.  A warning message “There are not enough communication channels to 
allocate” appears when user adds more than 100 ESD devices into ValVue3 device 
network view. For this case, please remove some of ESD devices from ValVue3 device 
network view to release the communication channels, and then try to add new ESD 
device again.

No limit on the number of communication channel when 
connecting with the devices such as SVI3, SVI II AP and 
SVi1000.
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Run Field Devices

User can run Masoneilan devices by device DTMs or ValVue3 Sequencer after the 
devices are added into ValVue3 device network view.

Using Device DTM
1. Select the device->Right click the mouse to have pop up menu->Click “Online 

Parameter”.

2. Connect Device DTM and wait until the DTM gets real status from PRM side ->Then 
configure device or run calibration test and diagnostic tests on the device through the 
device DTM.

Due to maximum number of concurrent opened devices is 5 
at PRM side, if connecting more than 5 device DTMs at the 
same time, performance from the 6th device will be very slow.
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Using ValVue3 Sequencer
1. Open Execute Sequencer window under ValVue3 Tools menu-> Choose a sequencer 

to run on the devices.

2. Execute Concurrent:

√ Turn on: The sequencer will be concurrently executed on all devices.

√ Turn off: The sequencer will be executed on the devices one by one.

3. Schedule At: Schedule a time to automatically execute the sequencer on the devices.

Due to maximum number of concurrent opened devices is 5 
at PRM side, if executing ValVue3 sequencer more than 5 
devices at one time, errors pops up starting from the 6th 
device.

To make sure sequencer can be successfully executed on 
multiple devices:

√ Option off “Execute Concurrent” before running 
sequencer 

√ Disconnect the devices before running 
sequencer

Please turn off ValVue3 Device Monitor Function that may 
cause communication error during the sequencer.
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4. Report Result: By default, this option is always ON. A sequencer report that contains 
positioner information and task result will be generated when all the devices finished 
the sequencer.

Configuration section cannot be displayed in the sequencer 
report if the sequencer is executed on multiple devices. This 
issue will be fixed in next release version.
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